DeploymentPro - System Requirements

In order for DeploymentPro to configure Outlook to connect to Office 365, each device must meet these system requirements:

  • Microsoft Windows 7 or later (With latest Windows updates), including TLS 1.2 support (for more information, see Microsoft's update information.
  • .NET Framework version 4.5 or later
  • These versions of Outlook:
    • Microsoft Outlook 2019 (Deploymentpro cannot reattach PST or migrate Autocomplete) 
    • Microsoft Outlook 2016 (with March 2016 PU)
    • Microsoft Outlook 2013 SP1 (with December 2015 PU)
    • Microsoft Outlook 2010 SP2 (with October 2015 PU, April 2015 PU).
      Note: Read the Outlook Updates article from Microsoft for more information.

 

Additional Information

  • Linux and Mac operating systems are not supported.
  • Microsoft Outlook 2007 is not supported.
  • Microsoft Store (UWP) Version of Outlook is not supported.
Was this article helpful?
3 out of 6 found this helpful