Error Message:
Retrieving the COM class factory for component with CLSID {29131539-2EED-1069-BF5D-00DD011186B7} failed due to the following error: 8007000e Not enough storage is available to complete this operation. (Exception from HRESULT: 0x8007000E (E_OUTOFMEMORY)). Action: TestCredentials.
Cause:
This error can be caused by an attempt to process a corrupt item, causing the Lotus Notes Client the Lotus Extractor leverages for migrations to drop into an infinite loop and fail a migration.
Resolution:
For each user affected by this error:
- Add the following folder filter ^BadMail to the "Filter folders (RegEx)" dialog box located on the Advanced Options page of the project.
- Make sure that Log subjects of failed items is checked in the Maintenance section.
- Stop the migration.
- Resubmit the migration.
- The migration will fail again. The folder location and size of the item causing the failure will be the most recent failed item error at the top of the Migration Errors list in the user migration information.
Note: This information will also be included in the Migration Statistics email, which can be requested from the main migration screen. - Open the Source mailbox, navigate to the folder location of the item causing the failure, and sort the items in the folder by size.
- Find items that match the exact size of the item failing the migration.
- Create a new folder named BadMail in the root of the Source mailbox and move the matching items into this folder, which will exclude them from the migration.
- Resubmit the migration.