Error
Duplicate Items in DropBox Migrations
Cause
This issue is a direct result of the Dropbox API, where sometimes a folder is presented as "Folder A", but the next time it's retrieved, it is instead presented as "folder a". This causes duplicate folders to be created at the Destination. This, in turn, results in duplicate items being created at the Destination, because the same items will then be migrated into the duplicate folders.
Resolution
If this occurs, there are two possible options:
- Ignore the duplicate items at the Destination.
- Advise users to perform an audit on the Destination folders, and if duplicate folders and items exist, delete them.