Lotus Notes移行のベスト プラクティス

Lotus Notesの移行では、Lotus Notes Extractorを使用します。設定とトラブルシューティングの情報については、Lotus Notes ExtractorのFAQを参照してください。Lotus Notesからの移行を設定および実行する際に必要な情報については以下を参照してください。 

Lotus Notesの移行計画

Lotus Notesの移行中、一部のデータは移行元で処理され、一時的に保存されます。アイテムは、1,000 アイテムごとにページを分割して検出されます。処理は以下のように実行されます。

  • 各ページは、50アイテムまたは 5MB のうち少ない方を一単位としてバッチ処理されます。
  • 処理済みの各アイテムは、一時的に、メールボックス内の非表示の一時フォルダーに保存されます。
  • 以下のいずれかが発生すると、非表示の一時フォルダー全体がクリーンアップされます。
    • GetPageOfItems が呼び出された時 (各ページごとに1000アイテムが取得されます。)
    • GetFullItems を使用したバッチ処理 (処理対象のアイテムのみの処理)が完了した時

アイテムの処理中は、読み取り、書き込み、および削除のアクションが発生し続けるため、移行を計画する際には、以下の点を考慮する必要があります。 

  • 一定した高い水準のディスクの入出力
  • 空きディスク領域の変動
  • 冗長ログはすべてのアクションをログに記録するので、リソースを過剰に使用する可能性があります。
  • 循環ログが有効化されていない場合、ログファイルがディスクの空き容量を急速に消費する可能性があります。

重要: 一部のウイルス対策プログラムは、Lotus Notes ExtractorによるLotusクライアントとメールボックスへのアクセスをブロックします。また、ExtractorがMigrationWiz にアクセスすることを妨げる可能性もあります。移行を開始する前に、Extractorがウイルス対策プログラムによってブロックされていないかを確認してください。

Lotus Notes管理者アカウントを設定する

管理者アカウントを1つのみ使用して、すべてのメールボックスを移行します。これにより、ユーザーのメールボックスごとにパスワードを指定する必要がなくなります。

Domino サーバーに管理者アカウントを設定するには、以下の手順に従ってください。

  1. Notes/Domino Administratorを開きます。
  2. メールボックスが配置されているサーバーを選択します。
  3. ファイル(Files)」タブに移動します。
  4. メールボックスが配置されているフォルダーを選択して右クリックします。
  5. メニューに移動して、アクセス制御の管理を実行します。
  6. 移行に使用するユーザーを選択します。
  7. このアカウントに、メールボックスへのアクセスに必要な権限を付与します。

管理者アカウントには、移行するメールボックス(NSFファイル)に対して次の権限が適用されている必要があります。

  • アクセス: 管理者
  • 文書の削除: 有効(この権限はデフォルトではありません。Dominoサーバーの容量が急激に消費されてしまうことを防ぐためには、手動で選択する必要があります。)

ユーザーリストのエクスポート

Lotus ExtractorはLotusクライアントと連携して、すべてのユーザーのリストを作成します。  Lotus Extractorは、初回の起動時に、「LotusExtractor.csv」という名前のCSVファイルを生成します。このCSVファイルは、MigrationWizへの移行のためにメールボックスを一括インポートする際に使用します。このファイルは、Lotus Extractor の実行ファイルと同じディレクトリに自動的に生成されます。「LotusExtractor.csv」が既に存在する場合は再生成されません。新しいCSVファイルを生成する必要がある場合は、既存のCSVファイルを削除して、Lotus Extractorを再起動します。生成されたファイルには、Dominoディレクトリで確認されたすべてのユーザーのメールアドレスが含まれています。 Lotus Notes移行ソリューションに必要なのは管理者資格情報で、「移行元ユーザー名(Source Username)」フィールド、および「移行元パスワード(Source Password)」フィールドはいずれも、LotusExtractor.csvやMigrationWizの一括アップロードでは使用されません。

手順:

  1. Lotus Extractorがインストールされているフォルダーを開きます。
  2. LotusExtractor.csvファイルを見つけます。
  3. LotusExtractor.csvファイルをデスクトップまたは別の場所にコピーします。
  4. コピーしたLotusExtractor.csvファイルを開きます。
  5. 「移行元メールアドレス(Source Email)」というタイトルの列を見つけます。
  6. 「移行元メールアドレス(Source Email)」列を除くすべての列を削除します。
  7. 「移行元メールアドレス(Source Email)」列に表示されたすべてのメールアドレスを移行対象とするかどうかを確認してください。この列のメールアドレスは、追加または削除が可能です。追加や削除を行ってもLotus Extractorに影響を与えることはありません。
  8. ファイルを保存します。

このようにして作成したリストは、「一括追加 (Bulk Add)]」フォームにコピーすることができます。

Lotus Notesアイテムと関連付けられたアイテムの種類を確認する

移行対象となるのはNotesサブシステムによって識別された種類のアイテムのみです。 Lotus Notesアイテムに関連付けられているアイテムの種類を確認します。

  1. Notesクライアントを起動します。
  2. メールを1件選択します。
  3. ファイル(File)」メニューをクリックします。
  4. プロパティ(Properties)」をクリックします。
  5. フォームのプロパティ(Form property​)」を検索します。
  6. 関連する値にチェックマークを付けます。

選択されたメールについて以下のような情報が確認できます。

スクリーンショット 

フォームのプロパティ(Form property​)」 が空白の場合、アイテムの種類が指定されていないためこのアイテムは移行されません。

Lotus Notes 会議室・リソース予約

Lotus Dominoは、1 つのデータベースファイル (Notes Storage Facility(NSF) ファイルとも呼ばれる) 内に複数のリソース・オブジェクトを格納できます。MigrationWiz Lotus Extractorソフトウェアは、会議室・リソース予約データベースに直接アクセスできません。これは、架空のユーザー文書を作成し、会議室・リソース予約データベースのコピーにリンクすることで解決できます。Extractorソフトウェアは、会議室・リソース予約データベースに紐づけされている架空のユーザー文書にアクセスしてデータを取得します。MigrationWiz内では、各リソース移行スレッドにフィルターが指定されているため、会議室・リソース予約データベースから適切な情報が抽出されて移行先に移行されます。

Lotus Domino のリソースの移行では、次の点を考慮してください。

  • Lotus Domino のリソースの移行は、常にメールボックス移行プロジェクト計画の最後に行うことをお勧めします。たとえば、MX とメールフローのカットオーバーが完了し、すべてのユーザーが新しいメール システムを利用している状態で、リソースデータを移行します。これにより、確実に最新のリソースデータを移行することができます。
  • 移行を予定しているリソースのために新しい移行プロジェクトを作成します。プロジェクトの「詳細オプション(Advanced Options)」で、最大同時移行数を3以下に設定します。これにより、対象の会議室・リソース予約データベースが移行元のDominoで過負荷になるのを防ぎます。
  • このプロセスには、Domino環境の再起動が必要になる可能性がある手順が含まれていることに留意してください。

移行プロセスの手順

1.リソースのユーザー文書を作成します。 MigrationWizには、移行元のLotus Dominoでリソース移行のエンドポイントとして使用するユーザー文書が必要です。この手順では、すべてのリソースの移行で使用される架空のユーザー文書を作成します。

  1. Lotus Domino Administratorを開き、「ユーザーとグループ(People & Groups)」>「Domain ディレクトリ(Domain’s Directory)」>「ユーザー( People)」に移動します。「ユーザー( People)」を右クリックし、「ユーザーを登録(Register Person)」をクリックします。
  2. 「基本(Basics)」タブで、架空のユーザーに名、姓、およびパスワードを指定します。「詳細(Advanced )」 チェックボックスをオンにし、「アドレス(Address)」 をクリックします。架空のユーザーに、resourcemigrationuser@yourdomain.com などの一意のインターネットアドレスを割り当てます。この値は、MigrationWiz 内の移行元のメールフィールドで使用されます。「すべて登録(Register All)」をクリックします。

2.現在の会議室・リソース予約データベースのコピーを作成します。 リソースデータの主体はカレンダーベースのアイテムです。ほかの移行ガイダンスでも説明されている通り、カレンダーデータの移行は、常に移行計画の最後の「完全移行(Full Migration)」サイクルで行うことをお勧めします。カレンダーデータの変更は頻繁に行われるため、早い段階でデータが移行されると、アイテムに加えられた重要な変更を移行できない場合があります。
この手順をメールボックス移行の最後に完了することで、確実にリソースデータの最新バージョンを取得して移行することができます。

  1. 現在の会議室・リソース予約データベースを見つけます。通常、このファイルはresource.nsfという名前で C:\Program Files (x86)\IBM\Lotus\Domino\data に格納されています。ファイルと場所は異なる場合があります。場所を確認するには、「ユーザーとグループ(People & Groups)」>「Domain ディレクトリ(Domain’s Directory)」>「メール受信データベース/リソース(Mail-In Databases and Resources)」>「Rooms」に移動し、いずれかのリソース文書を開きます。リソース文書内に「ファイル名(File name)」が表示されます。
  2. 前の手順で見つかったNSFファイルのコピーを作成し、C:\Program Files (x86)\IBM\Lotus\Domino\data\mail ディレクトリに配置します。この新しいファイルの名前は変更できます。ファイルの名前を変更したら、新しい名前を書き留めておいてください。

3.架空のユーザー文書を、コピー作成した会議室・リソース予約データベースに紐づけします。MigrationWiz は、リソースの移行に使用する移行アイテムとして、架空のユーザー文書を使用します。そのため、新しく作成されたユーザー文書を、C:\Program Files (x86)\IBM\Lotus\Domino\data\mail ディレクトリにコピーされたNSFファイルにリンクする必要があります。

  1. Lotus Domino Administratorを開き、「ユーザーとグループ(People & Groups)」>「Domain ディレクトリ(Domain’s Directory)」>「ユーザー( People)」に移動します。作成した架空のユーザー文書を、ダブルクリックで開きます。
  2. ユーザー文書を開いたら、「ユーザーの編集( Edit Person)」 をクリックし、「メールファイル(Mail File)」フィールドに移動します。「メールファイル(Mail File)」の値を、コピーしたNSFファイルの場所と名前に置き換えます。手順2では、NSFファイルが C:\Program Files (x86)\IBM\Lotus\Domino\data\mail ディレクトリにコピーされているため、指定する値は mail\yourfilename.nsf という書式にする必要があります。「保存して閉じる(Save & Close)」をクリックします。

4.会議室・リソース予約データベースのコピーに ACL エントリを設定します。 MigrationWiz Lotus ExtractorとDominoサーバーとの接続に使用する管理者アカウントには、会議室・リソース予約データベース(NSF)のコピーに対して管理者権限が付与されている必要があります。これによりExtractor はNSFからデータを取得できるようになります。通常は、Domino Administratorアプリケーションにログインするために使用されるアカウントです。

  1. Lotus Domino Administratorを開き、「ファイル(Files)」>「メールディレクトリ(mail directory)」フォルダーに移動します。作成/コピーされたNSFファイルを見つけます。NSF ファイルを右クリックし、「アクセス制御(Access Control)」>「管理(Manage)」に移動します。
  2. 「基本(Basic)」タブで、「ユーザー、サーバー、グループ(People, Servers, Groups)」の選択が 「すべて表示(Show All)」 に設定されていることを確認します。表示された一覧から、 Lotus Extractorのローカルサーバー管理者に使用されているユーザーを指定します。ユーザーをクリックして権限を「管理者(Manager)」 に設定し、「文書の削除(Delete Documents)」 チェック ボックスをオンにします。「OK」をクリックして権限を設定します。
    この時点で、Domino 環境の再起動が必要になる可能性があります。「ユーザーとグループ(People & Groups)」>「Domain ディレクトリ(Domain’s Directory)」>「ユーザー(People)」に移動して、新しくリンクされたNSFを開きます。作成済みのNSFのコピーがリンクされている架空のユーザー文書を検索します。架空のユーザー文書をクリックし、「メールを開く(Open Mail File)」をクリックします。メールファイルが開いたら、次の手順に進みます。NSFが開かない場合は、Dominoサーバーを再起動します。

5.リソースの移行プロジェクトを設定します。 リソース移行のために別途移行プロジェクトを設定し、MigrationWiz Lotus Extractorを使用したリソースの移行に合わせてプロジェクトをカスタマイズできるようにします。

  1. MigrationWiz ポータルにログインし、新しいメールボックス移行プロジェクトの作成を開始します。ツールに従って、必須フィールドに入力します。プロジェクト作成画面の左下にある「追加オプション(Additional Options)」をクリックします。
  2. 「追加オプション(Additional Options)」ページで、「最大同時移行数(Maximum concurrent migrations)」を最大 3 に設定します。3 より大きい値を設定すると、移行元のNSFファイルの過負荷によりデータが破損する可能性があります。すべての設定と資格情報を入力したら、「保存(Save) 」をクリックしてプロジェクトの作成を完了します。
  3. NSF内の各リソースに対してリソース移行エントリを作成します。
    • プロジェクト内のリソース移行エントリの「移行元メールアドレス(Source email)」フィールドには、常に、上記「1.リソースのユーザー文書を作成します。」セクションの手順 2で作成したアドレスを使用します。
    • 「移行先メールアドレス(Destination Email)」 フィールドは、移行先のリソースのメールアドレスになります。
  4. 各リソース移行エントリでは、その移行エントリに適したオブジェクトを抽出するため、「サポートオプション(Support Options) 」をカスタマイズする必要があります。リソース移行エントリを選択し、「編集(Edit)」アイコンをクリックします。
  5. 各リソース移行エントリ内に、対象のリソースの名前属性に基づいて、オブジェクトのフィルター処理の設定を行います。たとえば、"ConferenceRoom1/BitTitan Bellevue" というリソースの場合、リソース名は "ConferenceRoom1" 、サイトプロフィール名は "BitTitan Bellevue" になります。これに基づいて、「サポートオプション(Support Options) 」フィールドには次の情報を入力します。
    LotusNotesRoomResourceFilter=BitTitan Resource/BitTitan Site Profile
    上記のロジックは、 会議室・リソース予約データベースのコピー内で見つかった "ConferenceRoom1/BitTitan Bellevue" という名前のリソースをすべて移行します。
    • すべてのリソースの移行ではフィルターが必要です。移行サイクルを実行する前に、各リソース移行エントリにフィルターが設定されているかを確認してください。
    • リソースの名前は、リソースと、関連付けられたサイトプロフィール名で構成されています。
  6. プロジェクト内のすべての移行エントリに対してこの手順を繰り返し、データの移行先メールボックスにフィルターが正しく設定されているかを確認します。

6.Extractorを開始し、「完全移行(Full Migration)」を実行します。 MigrationWiz Lotus Extractorは、最初のユーザーマッピング時にCSV を生成します。CSVは、Dominoディレクトリを調査することで作成されます。一旦作成されたCSVを変更または再生成するためには、まず削除する必要があります。

  • Lotus Extractorをインストールして使用するには、コンピューターに .NET Framework バージョン4.6.1以降がインストールされている必要があります。現在インストールされている .NET Framework のバージョンを確認するには、Microsoftから提供されているこちらの資料を参照してください。 方法:インストールされている.NET Frameworkのバージョンを確認する:
  • この手順を行う前にMigrationWiz Lotus Extractorを実行済みの場合は、Lotus Extractorが解凍されたルートディレクトリにあるlotusextractor.csvファイルを削除する必要があります。現在処理中の移行がないことを確認し、lotusextractor.csvファイルを削除します。CSVファイルを削除したら、Extractor を再起動し、CSVファイルを再生成します。
  1. LotusExtractor.exeを開き、Dominoサーバーの管理者の資格情報と、手順5でプロジェクトを作成した際のMigrationWizの資格情報を使用してログインします。
  2. Lotus Extractorによる処理の準備が整ったら、プロジェクトの移行エントリを選択し、「開始(Start)」 > 「完全移行(Full Migration)」を選択します。

Lotus Notes MIMEコンテンツのログ

プロジェクトまたはユーザーの 「詳細オプション(Advanced Options)」に次のサポートオプションを追加することで、Lotus Notes MIME コンテンツログを有効にできます。  

LotusDumpMimeContent=.*

構文の説明:

Key = LotusDumpMimeContent

Value = the subject of the email

例:

LotusDumpMimeContent=.*

(すべてのメールのMIMEコンテンツを記録します。)

LotusDumpMimeContent=Welcome

(件名が「Welcome」のメールのみのMIMEコンテンツを記録します。)

ログは、LotusDumpMimeContent.txtという名前のテキストファイルに出力されます。このファイルは、MIME コンテンツのトラブルシューティングが必要なサポートチケットに添付します。

このテキストファイルは、プロジェクトで使用されているLotus Extractorと同じフォルダーに格納されます。

単一、複数、またはすべてのメールのMIMEコンテンツが出力されます。これによりMIME コンテンツが Lotus MIME変換ライブラリによって正しく生成されたかどうかを判断することができます。

Domino

Lotus DominoサーバーでLotus Notesの連絡先を同期する

Lotus Notesの連絡先は、ユーザーのローカルのハードドライブ内に .nsf ファイルとして保存されます。移行するには、各ユーザーが移行 (または完全/差分移行サイクル) を実行するに、Lotus Domino サーバー上で連絡先を同期する必要があります。

Lotus Notes 8以降から9.0.1の場合

Lotus Notes 9.0.1 より新しいバージョンはサポートされていません。

各ユーザーが自分のクライアントで、次の手順を実行する必要があります。

連絡先を手動で同期するには:

  1. Lotus Notesクライアントを起動し、セッションを開始します。
  2. 「ファイル(File)」メニューから、「プリファレンス(Preferences)」を選択します。
  3. 「連絡先(Contacts)」セクションで、 「複製と同期(Replication and Sync)」タブの「連絡先の同期を有効にする(Enable "Synchronize Contacts")」をオンにします。
  4. OK」をクリックします。
  5. 「ツール(Tools)」メニューから、「複製してすべて同期(Replicate and Sync All)」を選択します。 
  6. 開く(Open)」 > 「複製(Replication)」をクリックします。[開く] リストがある場合は、「複製(Replication)」アイコンをクリックします。
  7. 「有効(Enabled)」列の「連絡先の同期(Synchronize Contacts)」にチェックマークが付いていることを確認し、「複製の開始(Start Now)」をクリックします。 
連絡先を自動的に同期するには:
  1. スケジュールを開きます。
  2. 複製スケジュールのオプションを設定し、複製の実行、クライアントの起動またはシャットダウンをいつ行うかを定義し、「OK」をクリックします。​
  3. 次に「スケジュール(Schedule)」で、「複製スケジュールを有効にする(Enable Scheduled Replication)」を選択して有効にします。

Lotus Notes 6および7の場合:

各ユーザーが自分のクライアントで、次の手順を実行する必要があります。

  1. Lotus Notesクライアントを起動し、セッションを開始します。
  2. 「アクション(Actions)」メニューから、「アドレス帳の同期(Synchronize Address Book)」を選択します。

IBM Lotus Domino DAOS を使用した移行

MigrationWiz はネイティブAPI を使用して IBM Domino メールボックスのデータにアクセスしますが、DAOS サービスが実行されているかどうかで影響を受けることはありません。 Lotus Domino Object and Attachment Service (DAOS) は、Lotus Domino 8.5.0 で導入された、ディスク領域を節約するための機能です。 DAOS は、メールメッセージから添付ファイルを抽出して別な場所に移動し、代わりに、移動された添付ファイルへの参照情報を挿入します。DAOS は、C API呼び出し、エージェント、およびLotusScriptに対して完全に透過的です。

IBM DominoからOffice 365およびExchangeに移行する場合は、移行前にLotus Notesメールボックスのサイズ (メールファイルサイズとDAOSに格納されている添付ファイルの合計) が、Office 365またはExchangeのメールボックスの最大サイズを超えていないか確認してください。

メール受信データベースとアーカイブデータベース

基本的にMigrationWizでは、メール受信データベースや archive.nsf ファイルの移行はサポートされていません。ただし、いくつかの手順を行うことで、メール受信データベースとarchive.nsfファイルの移行に対応できるようにMigrationWizを設定できます。
注: この記事の内容は Dominoメール受信データベースに固有のものですが、archive.nsf ファイルにも有効です。 

メール受信データベースは、mail85.ntf、mail9.ntf などのメールファイル用テンプレートを使用して作成する必要があります。標準のLotus Dominoメール受信データベーステンプレート以外のテンプレートで作成されたデータベースの移行はサポートされていません。

  1. Dominoサーバー上に架空のユーザー文書を作成します。 架空のユーザーは、移行を実行するときに、MigrationWiz プロジェクトで使用されます。
  2. 「インターネットアドレス(Internet address)」フィールドがユーザーに割り当てられているかを確認します。MigrationWizは、この移行を識別するためにインターネットアドレスを使用します。
  3. LotusExtractorが既に実行されている場合は、"LotusExtractor.csv"ファイルを削除します。このファイルは、Dominoディレクトリに変更があった場合に再生成する必要があります。ユーザーを新規に追加することも変更に含まれます。
  4. 移行に使用する管理者アカウントが、新しく作成されたアカウントにアクセスできるかを確認します。管理者アカウントには、「文書の削除(Delete Documents)」を含め、「管理者(Manager)」権限が必要です。
  5. 「メールファイル(Mail File)」フィールドが移行対象のメール受信データベースまたはアーカイブデータベースを示すように、ユーザー文書を変更します。「メールファイル(Mail File)」フィールドの変更を保存した後、Dominoサーバーを再起動する必要があります。
  6. 架空のユーザーは、MigrationWizの通常の手順を使用して移行されます。 移行プロジェクト内の移行元メールアドレスとして、架空のユーザーのインターネットアドレスを使用します。移行先メールボックスには、メール受信データベースまたはアーカイブデータベースのデータが移行されます。カレンダーをメール受信データベースまたはアーカイブデータベースから移行する必要がある場合は、Dominoユーザー文書内の架空のユーザーのインターネットアドレスとメール受信データベースのインターネットアドレスは一致する必要があります。この移行はメールボックスの移行として実行されるため、MigrationWiz - メールボックスライセンス、またはUMB(ユーザー移行バンドル)ライセンスが必要です。

Lotus Notesのサポート

サポートに送信する調査用のLotus Notes NSFファイルについては、次の設定を行ってください。 

調査用のNSF ファイルをサポートに送信する前に、次の手順に従って、サポートにファイルへのアクセスを許可します。

  1. 「デフォルト(Default)」 および 「匿名ユーザー(Anonymous)」に管理者権限を設定し、「文書の削除(Delete Documents)」チェック ボックスをオンにします。

  2. ファイルが復号化されていることを確認します。

  3. 既定の設定でデータベースを圧縮します。

上記の 3つの手順の実行に加えて、サポートの際には、NSFファイルがどのバージョンのDominoで使用されているかという情報も重要です。NSFをBitTitanのFTPサイトにアップロードする前に、可能であれば、NSFファイル名にDominoバージョンを追加してください。例:Domino 8.5環境で使用されている Userx.NSF というファイルの場合は、アップロードする前にファイルの名前をDomino.8.5.Userx.NSFに変更します。または、NSFファイルの名前と、NSFファイルが使用されているDominoバージョンを記載したテキストファイル(.txt)と一緒に、NSFファイルをアップロードしてください。
例:
NSFファイル:Userx.NSF
Domino バージョン:8.5

この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています