Error
UID FETCH error: Can't fetch that data.
Cause
This error is caused by a well-known bug in the IMAP implementation used by your email server. This typically affects IMAP servers known as Zimbra email servers. The bug is documented on this page.
Internally, each IMAP message is assigned a unique ID (UID). MigrationWiz retrieves UIDs from the Source server to implement fast data retrieval and from the Destination server to prevent duplicates when performing multi-pass migrations. However, because of a bug in some IMAP implementations, MigrationWiz is unable to retrieve UIDs from the IMAP server.
Resolution
Upgrade Your IMAP Server
Consider upgrading your IMAP server to a version that contains a fix for this well-known bug.
Suppose your IMAP server cannot be upgraded, and the IMAP server reporting the error is the Destination server (not the Source server) for your migration. In that case, the following workaround can be used: Disable Duplicate Detection for the entire project
- Sign in to your MigrationWiz account.
- Click Mailbox Migration.
- Locate and edit your Mailbox Project.
- Click Advanced Options.
- Under Support, checkmark the Do not search Destination for duplicates option.
- Click Save.
MigrationWiz stops fetching UIDs from the Destination server by disabling the search for duplicates. As a result, the error is not encountered. Note that duplicate prevention is still in effect, but only as long as you use the same mailbox object. For example, if you perform multiple migrations using the same MigrationWiz mailbox record, no duplicate will be created. However, we cannot guarantee protection against duplicates if you recreate the MigrationWiz mailbox record.