Invalid Message Range Specified Error

Error

Invalid message range specified.

Cause

This error is caused by a well-known bug in the IMAP implementation used by your email server. This typically affects IMAP servers known as DBMail email servers. The bug is documented here.

Internally, each IMAP message is assigned a unique ID (UID). MigrationWiz retrieves UIDs from the Source server to implement fast data retrieval and from the Destination server to prevent the creation of duplicates when performing multi-pass migrations. Because of the bug in some IMAP implementations, MigrationWiz is unable to retrieve UIDs from the IMAP server.

Resolution

Upgrade Your IMAP Server

Consider upgrading your IMAP server to a version that contains a fix for this well-known bug.

Disable Duplicate Detection

If your IMAP server cannot be upgraded, and the IMAP server reporting the error is the Destination server (not the Source server) for your migration, the following workaround can be used:

  1. Sign in to your MigrationWiz account
  2. Click on Mailbox Migration.
  3. Click on Migrate Mailbox.
  4. Select your Mailbox Project.
  5. Click on View Mailboxes.
  6. Select your Mailbox.
  7. Click on Edit Mailbox.
  8. Click on Show Advanced Options.
  9. Checkmark the box for Do not search Destination for duplicates.
  10. Click on Save.

Important

You can also set the same Advanced Option on the project. In this case, the setting will apply to all mailboxes in this project.

MigrationWiz stops fetching UIDs from the Destination server by disabling the search for duplicates. As a result, the error is not encountered. Note that duplicate prevention is still in effect, but only as long as you use the same mailbox object. For example, no duplicate will be created if you perform multiple migrations using the same MigrationWiz mailbox record. However, we cannot guarantee protection against duplicates if you recreate the MigrationWiz mailbox record.

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