Error
ErrorConnectionFailed: We were unable to connect to the server.
Cause
The most common cause encountered is the network over-utilization. This means that you are attempting to migrate too many mailboxes simultaneously, and do not have enough bandwidth to execute them.
Resolution
Attempt to open your OWA URL from an external network from a system not joined to your domain. If OWA is loaded promptly, check your server resources:
- Check server CPU usage.
- Check memory usage.
- Check disk I/O usage using a performance monitor.
- Check for over-utilization of the network.
Set Maximum concurrent migrations. To be very safe, we recommend initially setting this to 5. This means that when all mailboxes are selected and the migration begins, only the first five (5) mailboxes in the list will be migrated (using parallel processing), and when the first of the five (5) completes, the next in the list will begin migrating, and so on down the list through to completion of all mailboxes.
If the Source server has enough server resources, set this parameter based on the bandwidth guideline of three (3) mailboxes per 1Mbps of bandwidth. Therefore, for example, if there is a 10Mbps connection, we recommend that the maximum concurrent migrations parameter be set to 30.