Error
ErrorCalendarInvalidTimeZone.
Cause
Calendar items cannot be processed because your client access Exchange server is missing a definition for the reference UTC / GMT zone.
Resolution
To verify if the UTC / GMT zone is missing use OWA:
- Open OWA (Outlook Web Access) for any mailbox
- Go to Options.
- Select Regional Settings.
- Expand the Current Time Zone combo box.
- Check if (GMT) Coordinated Universal Time is present.
- Cancel changes (only check if the time zone is defined - do not change it).
To verify if the UTC/GMT zone is missing use the Windows registry:
- Login to the Exchange Server(s) providing client access.
- Start regedit.
- Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones.
- Check if a UTC registry sub-key is present.
Once you have verified the problem, ensure the reference UTC/GMT timezone is defined on your Exchange server.