ErrorCalendarInvalidTimeZone

Error​

ErrorCalendarInvalidTimeZone.

Cause

​Calendar items cannot be processed because your client access Exchange server is missing a definition for the reference UTC / GMT zone.

Resolution

To verify if the UTC / GMT zone is missing use OWA:

  1. Open OWA (Outlook Web Access) for any mailbox
  2. Go to Options.
  3. Select Regional Settings.
  4. Expand the Current Time Zone combo box.
  5. Check if (GMT) Coordinated Universal Time is present.
  6. Cancel changes (only check if the time zone is defined - do not change it).

To verify if the UTC/GMT zone is missing use the Windows registry:

  1. Login to the Exchange Server(s) providing client access.
  2. Start regedit.
  3. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones.
  4. Check if a UTC registry sub-key is present.

Once you have verified the problem, ensure the reference UTC/GMT timezone is defined on your Exchange server.

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