Error Message
Cannot create '<filename>' because another file exists with the same name.
Cause
OneDrive doesn’t allow multiple files to share the exact same name. For example, if you are migrating from Google Drive to OneDrive, you could run into an instance where the error message is generated.
Resolution
Activate the Advanced Option RenameConflictingFiles to automatically rename the files that have the same name. This will rename the files to their original file names, followed by a unique identifier hash so it does not interfere with the original name and search. Use the following steps to do so:
- Sign in to your MigrationWiz account.
- Click on the Projects tab if you do not see your Project listed.
- Click on the name of your Project in the list.
- Click on the Edit Project button.
- Click on the Advanced Options button.
- Under Support, in the Support options text field, add
RenameConflictingFiles=1
and click on the "+" to add it to your project. - Click on Save Options.
- Back in the Project list, select the users that encounter the error.
- Click on Reset Items.
- Click on Start.