Error
Connection did not succeed. Try again later.
Cause
This error may occur for the following reasons:
-
Insufficient mailbox permissions, one or more of the following requirements are not fulfilled.
- Your admin account must be a global admin role.
- You must have a mailbox you can log in to using OWA.
- Sufficient permissions.
- Connection throttling, the admin account was used to migrate multiple mailboxes, and Exchange throttled concurrent connections. For example, Microsoft 365 only allows 10 simultaneous connections per admin account.
- Mailbox Provisioning, a mailbox was provisioned shortly before initiating migration, and the mailbox wasn't fully available. For example, Microsoft 365 will frequently return this error if a mailbox is submitted immediately after provisioning, due to data center replication delays.
- Excessive Server Load, the target server was under an excessive load and started returning this error. For example, Microsoft 365 servers usually experience high load at specific times such as Fridays (evenings) or Mondays (mornings).
Resolution
We recommend trying the following:
- If using administrative credentials, using API permissions will likely resolve the issue.
- In many cases, replication or server load issues are resolved simply by waiting a few minutes.
- Check the admin account:
- Make sure it is a global admin (Microsoft 365).
- Make sure it has a mailbox that can be logged in to (use OWA).
- Consider granting explicit permissions to all mailboxes.
- Check throttling limits:
- Decrease the number of simultaneous migrations. The default Exchange 2010 limit is 10.
- Consider creating more than one connector, each using a different admin account.