Error: "We've encountered an error with OutlookConfigurator. Access is denied."

Antivirus and antimalware software running on client machines can sometimes block the functionality of the Device Management Agent (DMA) and DeploymentPro. Various error messages can occur indicating that this is the case.

Error Source

DMA and DeploymentPro

Error Message

We've encountered an error with OutlookConfigurator. Access is denied.

Description

When DeploymentPro creates a new profile, it leverages the module OutlookConfigurator. The application will display the error message with a red X if it is unable to complete the profile if the customer's antivirus software has quarantined one of DeploymentPro’s executable files.

Log files will display something similar to the following.

2017-09-26 23:48:06|Error|BitTitan.DeviceManagement.OutlookConfigurator.Core.OutlookConfiguratorEngineManager.LaunchProcess|2324|6|Failed to start process C:\Users\licensing\AppData\Local\BitTitan\DeviceManagementAgent\module\OutlookConfigurator\OutlookConfiguratorApplication.Launcher.ApplicationLauncher.exe, error: System.ComponentModel.Win32Exception (0x80004005): Access is denied

Cause

Client antivirus software has quarantined one of DeploymentPro’s executable files.

Additional information

This error message can also be caused by two other issues.

  1. The version of Outlook 2010 needs to be Outlook 2010 (14.0.7188.5000) April 2015 or newer. Older versions are not compatible.
  2. If 32-bit Outlook is installed, and the 64-bit version is selected, this error may display: BitTitanDMAOutlookConfigurator.exe is 32-bit and BitTitanDMAOutlookConfiguratorApplication.exe is 64-bit.

If the issue is not identified by the OutlookConfigurator files, or either of the alternative issues, then escalate immediately.

For more information: Read the Antivirus Application Blocking Errors article.

Resolution

Enter an exclusion in the antivirus policy for the %LocalAppData%\BitTitan folder.

Was this article helpful?
0 out of 0 found this helpful