Error Message
Failed to verify Microsoft 365 Credentials.
Cause
This error can be caused due to:
-
Wrong credentials
This error can occur due to credential issues with either the source or destination endpoint settings. The error indicates that either the Administrator Username or Password is incorrect hence they cannot be verified. -
Insufficient Administrator rights of the endpoint account
This may happen when the user does not have sufficient administrator rights. A Global Administrator would be needed, this consent can be granted at the endpoint.
Resolution
Important
Avoid the Failed to Verify Microsoft 365 Credentials error message, ensuring that the application approval/consent is given before clicking on the Verify Microsoft 365 Credentials in the endpoint configuration page.
Solve this issue by following one of the following workarounds.
Check your Administrator Credentials
Follow the steps below
- Check the Administrator Username for any typos.
- Verify that the Administrator Password field has not been left blank.
- Verify that the Password is correct.
Check Administration Consent
If Source or Destination users have not consented to the FullAccess or Delegate Access applications respectively, an error Check your Administrator Consent appears.
To resolve this issue, enable the necessary permissions and consent to the app access when prompted based on your specific situation, as described below.
- Click the permission link in the Endpoint configuration.
Important
The link will change according to the endpoint you are configuring. In the image above, we are configuring the source endpoint, so we must click and enable the MigrationWiz-PCH-FullControl permission. - If you close the configuration endpoint window, enable the respective permissions by going to MigrationWiz-PCH-FullControl for the source or MigrationWiz-PCH-DelegateAccess for the destination.