Error Message
Failed to add user1@domain.com as a member to team team_name: Could not find matching user at destination tenant.
Cause
This happens when a member or owner of a team either does not exist in the destination or the user's email prefix in their UPN address is different in the destination.
Resolution
Use the advanced option UserMapping="user1@source.com->user.one@destination.com" to set the new or correct name for each user that exists in the destination.