Error
Invalid administrative credentials for Google discovery; Cannot connect to Contact API (denied) Failed
Cause
If this error occurs during the auto-discovery of items for a Google tenant, it is because of either:
- The administrator account specified in the endpoint does not exist.
- The Google scopes are not set up correctly.
Resolution
To resolve this issue please review the following information.
Administrator Account Does not Exist
You will need to update the endpoint and provide a valid administrator account.
Google Scopes Are not Set Up Correctly
You will need to verify the API Scopes are configured correctly. Reference the appropriate article for which endpoint type is configured in the project.
G Suite (IMAP) - Enable access to G Suite (IMAP) using OAuth 2.0
G Suite (Gmail API) - MigrationWiz – Mailbox Migration – Set up Google API for migrating mailboxes