Error: Cannot connect to <endpoint> (Access denied)

Error

This error has two possible messages:

  • Cannot connect to <Google endpoint> (Access denied).
  • We tried to connect to the given Google API scope, but Google replied with "Access denied".

Cause

The two possible reasons for this are:

  • The administrative authentication setup has not been completed.
  • The account you are trying to migrate does not have the related service enabled (e.g., the calendar application is disabled).

Resolution

To address this issue, please review the following information and apply the solution that best fits your case.

  • Make sure your administrative OAuth 2.0 authentication setup is correct by following the instructions in the article Enable access to G Suite using OAuth 2.0.
  • Make sure that the user you are migrating has the related service enabled. For example, if we cannot authenticate the calendar API, make sure that Google Calendar is enabled for this user.
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