Error
Error: Cannot connect to Calendar API: Unauthorized Client. Client is unauthorized to retrieve access tokens using this method.
Cause
This error occurs when calendars for mailboxes undergoing migration have been disabled in the Google Admin Console, or when the GSuite Admin has failed to input the OAuth2 API Scopes.
Resolution
The best is to contact your customer to determine if the calendar services were turned off, the API Scopes entered as needed, and if the calendars for the affected mailboxes need to be migrated. If the calendars need to be migrated, then the service and API Scopes must be active.
Read the following articles on activating the calendar service and entering the API Scopes:
You can retry the migration once the above is confirmed.